Results 1 to 6 of 6

Thread: Handling problems and i have no idea what the prob can be...

  1. #1
    Senior Member Hermann's Avatar
    Join Date
    Nov 2012
    Location
    Stellenbosch
    Posts
    144

    Handling problems and i have no idea what the prob can be...

    Hey guys i need some info here hope someone can help,So ive been running my car for about 3 weeks now with no probs what so ever but yesterday the car car started with something that i have not seen before when i run from 0-80% throttle its straight as an arrow but as soon as i hit full throttle it just darts to the right i cant understand this, ive been running it full throttle no prob and suddenly yesterday it started. at first i thought i broke a cvd but they are all fine then i checked the diffs also all good checked the steering column its also fine then adjusted the droop thought its maybe picking up a wheel but no thats also not the prob so i am out of ideas now...
    Last edited by Hermann; 02-05-2016 at 08:09.

  2. #2
    Administrator Vimal's Avatar
    Join Date
    Sep 2010
    Location
    Wynberg, Cape Town, South Africa
    Posts
    3,628
    If you still running the oneway in the DD then replace the part that goes into the oneway bearings. It's a common problem with the original parts. I replaced the bearings and the outdrive bits.

    Tamiya TB EVO 5 RWD
    Tamiya TB EVO 4 RWD WIP
    DB01RR Buggy (Durga)
    10.5T 60A Hobbywing Quickrun
    13.5T 45A Hobbyking combo
    BlueBird 621 digital servo

  3. #3
    Senior Member Hermann's Avatar
    Join Date
    Nov 2012
    Location
    Stellenbosch
    Posts
    144
    Hey Vimal its not the dd sold that its my racing chassis it has a solid diff infront

  4. #4
    Senior Member Hermann's Avatar
    Join Date
    Nov 2012
    Location
    Stellenbosch
    Posts
    144
    I stripped the chassis completely looking for the problem could not find it rebuilt it and it was fine for around 2 laps then it dit it again but ill try replacing the side shafts hope it works thanks

  5. #5
    Senior Member
    Join Date
    Nov 2008
    Location
    Centurion South Africa
    Posts
    295

    Problems

    Herman Your car is "tweaked" by that it means that the wheels do not have the same weight, or for a better understanding, are equally sprung on the ground. A simple test is to lift the car in the front and back by placing your wrench in the middle of the car, resting it on a flat surface, and lifting the car up to see which wheel lifts first of the ground first. If your car has droop screws on the A arm you need to adjust them so they come into contact with the chassis at the same time, AND at the same time make sure the shocks are travelling up and down in equal length. This is quite a mouthful but for better understanding goto XRay`s website and download the Complete Setup Book, this is a must for every racer out there. Hope it helps.
    Top Racing PHOTON EX, SABRE FD2 ,AE TC3 x3, CYCLONE FOCUS

  6. #6
    Junior Member
    Join Date
    May 2017
    Posts
    1
    Quote Originally Posted by Hermann View Post
    I stripped the chassis completely looking for the problem could not find it rebuilt it and it was fine for around 2 laps then it dit it again but ill try replacing the side shafts hope it works thanks
    Hey Herman, mines kind of doing the same thing. Did you find out what was causing it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •